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Scene Builder is a popular tool that enables developers to 
create Java user interfaces (UIs) using an intuitive drag-

and-drop approach. It was initially created and maintained 
by Oracle and open-sourced. Since March 2015, Gluon has 
distributed the releases of Scene Builder for Mac, Linux, and 
Windows systems. In that time, there have been more than 
400,000 downloads of the tool. Gluon continues to develop 
Scene Builder. In this article, I discuss how to use the tool. 
For readers familiar with Scene Builder from the days when 
Oracle distributed it, this will serve as both a refresher and 
an update. 

About Scene Builder

UIs for Java client applications can be created programmati-
cally using JavaFX code, or declaratively, using FXML code. 
The declarative approach requires FXML, which is a for-
mat based on XML and well documented by Oracle. While 
it is possible to create complete UIs writing directly FXML 
code, it is a tedious process. Fortunately, you can design a 
UI interactively using Scene Builder, which then translates 
your UI into FXML that can be used together with other 
JavaFX code.

In practice, many applications contain both JavaFX code 
and FXML code. The JavaFX APIs and the FXML constructs are 
designed to work together.

How It Works

On the JavaFX code side, the FXMLLoader class loads an FXML 
ile from the JAR containing the application ile or from the 
classpath: 

FXMLLoader.load(getClass().getResource("FXML.fxml"));

The connection between your Java code and the UI elements 
that are declared in the FXML ile is made by a controller 
class. This is a regular Java class that may contain annota-
tions linking the UI elements to Java classes. This approach 
separates the UI declaration from the behavior of the applica-
tion, while still allowing the application to access the UI ele-
ments directly.

The loader will ind the name of the controller class, as 
speciied by fx:controller="your.package.name.FXML 
Controller" in the FXML ile. Then the loader creates an 
instance of that class, in which it tries to inject all the objects 
that have an fx:id tag in the FXML ile and are marked with 
the @FXML annotation in the controller class. Finally, when the 
whole FXML ile has been loaded, the FXMLLoader will call the 
controller’s initialize method.

Although the FXML ile can be edited within any IDE as a 
regular XML ile, this practice is not recommended, because 
the IDE provides only basic syntax checking and autocomple-
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tion but not visual guidance. A better approach is to open the 
FXML ile with Scene Builder.

Installing Scene Builder

You can install Scene Builder by downloading it. Make sure to 
download the right version for your operating system. Then 
follow the platform-speciic instructions for installing it in 
the default location, or select a custom location if you are 

installing it on Windows. (This is a new feature available in 
Scene Builder 8.3.0.) Once you have installed Scene Builder, 
open your IDE so you can set its location and you can open 
any FXML ile from your IDE:

■■ On NetBeans, select Tools -> Options (or Preferences on 
Mac) -> Java -> JavaFX, and click Browse to ind the main 
Scene Builder folder.

■■ On IntelliJ, select File -> Settings (or Preferences on Mac) 

Figure 1. Adding containers and controls
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-> Languages & Frameworks -> JavaFX, and browse for the 
application path.

■■ On Eclipse, select Window -> Preferences (or Preferences on 
Mac) -> JavaFX, and browse for the application path.

Whenever you have an FXML ile, you will be able to edit it 
with Scene Builder simply by right-clicking it and selecting 
Open with Scene Builder.

Creating a Basic Interface

You can open an existing FXML ile with Scene Builder, or 
you can open the Scene Builder application and create a new 
FXML ile. 

Creating a UI with Scene Builder is easy. You can drag and 
drop containers and controls to your view. Let’s step through 
an example.

To begin with, open Scene Builder, and select Start New 
Project from the Welcome menu. For mobile projects, a built-
in Gluon Mobile theme is set. If you want to create a regular  
JavaFX project, you can do this by selecting the Modena 
theme from Preview -> JavaFX theme -> Modena (FX8). 

Add a main container for your scene. In this example, I 
will add a BorderPane. You can drag a BorderPane from the 
Containers left panel to the middle of the screen or to the 
hierarchy panel.

In a similar way, you can drag and drop any JavaFX built-
in container or control (see Figure 1, previous page). You can 
use the Library Manager to include libraries containing cus-
tom controls. The online documentation can help with any-
thing that’s not intuitive.

A Hierarchy panel is available. It shows the hierarchy  
of containers and controls. If you want to use containers  
and controls in your Java code, you need to tag them with 
fx:id. This can be done in the Code right panel. This fx:id 
tag is a very important concept, because it bridges the world 
of the designer using Scene Builder with the developer code 
in an IDE.

If you want to have interactions between the FXML ile 
and your Java code, you need to specify the name of the con-
troller class. This name should be added to the FXML ile in 
the Controller panel. You open the Controller panel by click-
ing the widget in the lower left corner. 

If you want to access UI elements from your Java code (via 
the controller class), you need to make sure the value provided 
in the fx:id tag is exactly the same as the value of the @FXML 
annotation for the corresponding ield in the controller class.

To make this easier for the developer, and to avoid typos, 
Scene Builder can generate a sample controller skeleton for 
you. This sample controller is auto-generated Java code that 
contains FXML-annotated ields for all UI elements that are 
tagged with fx:id.

You can easily copy the diferent nodes to the controller 
by selecting View -> Show Sample Controller Skeleton. Click 
the Copy button, and on your IDE paste the content into the 
controller class. 

Typical code will look like Listing 1. 

Listing 1. Sample Skeleton

import com.gluonhq.charm.glisten.control.AppBar;

import com.gluonhq.charm.glisten.control.Avatar;

import javafx.fxml.FXML;

import javafx.scene.control.ScrollPane;

import javafx.scene.layout.StackPane;

public class GluonFXMLSampe {

    @FXML

    private AppBar appBar;

    @FXML

    private StackPane stackPane;

    @FXML
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    private ScrollPane scrollPane;

    @FXML

    private Avatar avatar;

}

 

You can easily add CSS to the scene by providing a CSS ile 
that can be included using the Stylesheets option in the 
Properties panel on the right. You can add inline styling also, 
by providing style rules to any node on the scene. You can 
apply new or existing style classes to any node as well.

Features related to layout, such as position, dimensions, 
margin, padding, and transforms (translation, rotation,  

Figure 2. Defining anchor pane constraints in the Layout panel
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scaling, and so forth), can be set in the Layout right panel, as 
shown in Figure 2.

At any moment, you can preview the created scene by 
clicking Preview -> Show Preview in Window. A resizable  
dialog box with the designed scene will be shown. By resizing 
it, you can make sure every node behaves as expected.

Integrate the Basic Interface in a Java App and Show It

Once the FXML is ready, you can integrate it into your Java 
application by calling FXMLLoader to load it. Here’s how:

public class GluonSceneBuilder extends Application {

    @Override

    public void start(Stage stage) throws Exception {

        Parent root = FXMLLoader.load(getClass()

                      .getResource("GluonFXML.fxml"));

        

        Scene scene = new Scene(root);

        stage.setScene(scene);

        stage.show();

    }

}

In the controller class, you can add the required action han-
dlers and the response to the user interaction. You can create 
new controls as well, and combine them with those injected 
by the FXMLLoader. Notice that for the controls you add pro-
grammatically, you need to create new instances. This is 
not needed for controls that are declared in the FXML ile, 
because the FXMLLoader already creates them for you. The 
code snippet below shows a piece of a controller class that 
works with two controls: an HBox control deined in the FXML 
ile, and a Label that is not created in the FXML ile. The HBox 
instance does not need to be created in the controller class, 
but the Label instance does.

@FXML

private HBox hBox;

  

private Label label;

public void initialize() {

    label = new Label();

    hBox.getChildren().add(label);

    titledPane1.expandedProperty()

      .addListener((obs, ov, nv) -> {

         if (nv) {

            label.setText("TitledPane1");

         }

      });

      . . .

}    

In a controller class, you can annotate not only ields repre-
senting controls with the @FXML annotation, but also meth-
ods. As an example, I deine the following event handler in 
the controller:

@FXML

void buttonClicked(ActionEvent event) {

    label.setText("Button");

}

This event handler simply sets the text of the Label to 
"Button". Because the event handler annotated it with @FXML, 
Scene Builder will ind it and can assign it to a corresponding 
action for a node.

Integrate the Interface with Your Favorite IDE

Scene Builder is a standalone application. When FXML is 
being edited outside Scene Builder (by directly modifying it 
in your IDE, for example), Scene Builder reacts to the changes 
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made in the FXML itself or in the CSS iles after those 
changes are saved. Scene Builder also manages to ind the 
controller and the diferent nodes annotated with @FXML. 

If you prefer to use Scene Builder fully integrated with 
your preferred IDE, IntelliJ ofers this option by using the ver-
sion of Scene Builder installed in your system. Note that not 
all options are supported. For example, there is no support for 
menus, and custom controls are not allowed.

For Eclipse, there is no built-in integration, but there is 
a Preview option. On Window -> Show View -> Other select 
JavaFX -> JavaFX Preview. That option works like the Preview 
option on Scene Builder, and you can interact with it. In addi-
tion, by toggling the Load controller button, it applies the 
controller and works as if you were running the application 
embedded in the Preview panel. However, it doesn’t work 
with custom controls.

Community Enhancements in Scene Builder

Although most of the Scene Builder code was contributed by 
Oracle, the end product is really a synergy between Oracle 
and the JavaFX community. The code for Scene Builder is 
now being maintained by Gluon, but it contains contributions 

from many individuals and companies in 
the JavaFX community.

As a consequence, many major and 
minor bug ixes have been applied in Scene 
Builder, and new functionality has been 
added. As with any open source project, 
anyone can report a bug or submit a pull 
request with a proposed feature or ix.

Among the most recent improvements 
to Scene Builder are that it now works with 
an optimized set of imports, and other 
new features such as a design-time lag. 
The design-time lag allows developers to 
provide diferent behavior for their con-

trols during design time. This ability makes it much easier to 
work on complex controls, such as controls that at runtime 
require connections to external resources and databases that 
are not available at design time. One of the most commonly 
requested functionalities is better integration with third-
party libraries that are available via public repositories. In 
the past, developers had to manually upload those libraries 
in Scene Builder. Starting with Gluon Scene Builder 8.2, the 
Maven Central repository is fully supported, allowing search-
ing, downloading, and installing for any third-party library 
available in Maven Central or even private repositories. You 
can access these features by selecting the JAR/FXML Manager 
option, as shown in Figure 3.

Scene Builder then inspects those libraries, and the 
controls it inds in the libraries are added to the Custom left 
panel so they can be easily included in the FXML ile.

Conclusion

Scene Builder is a tool originally developed by Oracle that 
enables developers to create UIs using an intuitive drag-and-
drop interface. Thanks to the @FXML annotation and the ability 
to assign identiiers and event handlers to controls in Scene 
Builder, the worklow between Scene Builder and your JavaFX 
application code is easy. </article>
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Figure 3. The JAR/FXML Manager menu


